gentoo error dev-lang/python-2.5.4-r4 failed Wittenberg Wisconsin

Address 1007 S Superior St, Antigo, WI 54409
Phone (715) 623-2468
Website Link http://www.northwoodscomputerguy.com
Hours

gentoo error dev-lang/python-2.5.4-r4 failed Wittenberg, Wisconsin

Still no luck: These are the packages that would be merged, in order: Calculating dependencies... Installing libffi worked and we got a newer python, installed with -nodeps though.  Portage upgrade worked after that also. They are marked in ebuilds for a reason but with some luck we can ignore them and maybe get something semi-working out of it. The contents of this document, unless otherwise expressly stated, are licensed under the CC-BY-SA-3.0 license.

done!
[ebuild †NS † ] dev-lang/python-2.5.4-r4 †USE="gdbm ncurses readline
ssl threads (wide-unicode) xml -berkdb -build -doc -examples -ipv6
-sqlite -tk -wininst" 0 kB

Total: 1 package (1 in new slot), Single > will just overwrite it. I'd try > again with MAKEOPTS=-j1 in case something was executed out of order and in > parallel, but that's just a tip, no idea if this might help. Good.

Questions or comments? But I'm eager to learn, would be great if someone could tell > me where to look for debugging infos. This is an important step, because portage can not possibly know, that we installed something with -nodeps and now it might not work as intended. com [Download message RAW] what is the output of "eselect python list" On Thu, May 20, 2010 at 11:43 AM, Rene Lopez Montelongo < [email protected]> wrote: > Hi everyone > I'm

Tweet No related posts. Please feel free to contact us. © 2001–2016 Gentoo Foundation, Inc. But I'm eager to learn, would be great if someone could tell me where to look for debugging infos. Close This site uses cookies for advertising.

gentoo.org sites gentoo.org Wiki Bugs Forums Packages Planet Archives Sources Infra Status Archives Toggle navigation Home All Archives gentoo-user Gentoo Archives: gentoo-user From: Moritz Schlarb To: [email protected] Subject: [gentoo-user] Re: done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.3.6-r4, Contents reflect the opinion of the author, not the Gentoo project or the Gentoo Foundation. Specially those that do more than -r (revision) version upgrades and that do some uninstalls.

com> Date: 2010-05-21 1:29:30 Message-ID: AANLkTin1GTU3k9r2ieZti46Hcxn4xK7-7jucaEt4BkmS () mail ! python-updater is a no go, as it needs newer python of course. But I'm eager to learn, would be great if someone could tell >> me where to look for debugging infos. > > Look at yout build.log, line 942, a libpython2.5.so.1.0 cannot Looking at  /usr/portage/sys-apps/portage/portage-2.1.10.11.ebuild we can find a row declaring: build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] )
so lets mask python 2.7 echo  ">=dev-lang/python-2.7" >>/etc/portage/package.mask
Please notice the >> this

gmail ! cat /usr/portage/dev-lang/python/python-2.6.6-r2.ebuild | grep pkgconfig
dev-util/pkgconfig
We might be in luck just a pkgconfig is needed. the next logical step is to remove package masks we added. Gentoo is a trademark of the Gentoo Foundation, Inc.

If you continue to use the site, you accept the use of cookies.more info jump to the content Gentoo.LinuxHowtos.org howtos, tips&tricks and tutorials for gentoo linux from small one page howto done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.7.1-r1 [2.3.6-r4, done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.3.6-r4, then system, then world There is no direct route to take if upgrading old Gentoo systems.

Contents reflect the opinion of the author, not the Gentoo project or the Gentoo Foundation. All sorts of circular dependencies come up. www.tracemycash.com Other free services toURL.orgShorten longURLs to shortlinks likehttp://tourl.org/2 tourl.org . Any version.

Look at yout build.log, line 942, a libpython2.5.so.1.0 cannot be found. We do have pkgconfig 0.22 /var/db/pkg/ gives a hint here. Sorry, my time is up, Wonko Replies Subject Author [gentoo-user] Re: Failed to emerge dev-lang/python-2.5.4-r4 Moritz Schlarb Report Message Find on GMANE Find on MARC All times displayed are in I don't know why, and I have no time to look further right now.

Get Gentoo! The contents of this document, unless otherwise expressly stated, are licensed under the CC-BY-SA-3.0 license. Nevermind! ;) Am 14.09.2011 02:52, schrieb Alex Schuster: > Moritz Schlarb writes: > > >> /usr/bin/install -c -m 644 pyconfig.h >> /var/tmp/portage/dev-lang/python-2.5.4-r4/image//usr/include/python2.5/pyconfig.h >> emake failed >> * ERROR: dev-lang/python-2.5.4-r4 failed (install Back to the beginning then.

programs through a TCP/IP sockAdded to portage2016-10-17 vdr-vompserver - 0.4.1-r1Ebuild name:media-plugins/vdr-vompserver-0.4.1-r1DescriptionVDR Plugin server part for MediaMVP deviceAdded to portage2016-10-17 xf86-video-nouveau - 1.0.13Ebuild name:x11-drivers/xf86-video-nouveau-1.0.13DescriptionAccelerated Open Source driver for nVidia cardsAdded to portage2016-10-17 You are here: Portage Details of virtual/mpi: Description: Virtual for Message Passing Interface (MPI) v2.0 implementation Homepage: available versions: releasesalphaamd64armhppaia64mipsppcppc64ppc macoss390shsparcx86USE-Flagsdependenciesebuild warnings mpi-2.0-r4 ~~~~--~~----~cxxfortranromiothreadsshowshowmpi-2.0-r3 ++-++-++---++cxxfortranromiothreadsshowshowLegend:+ stable~ testing- not availablesome ebuild warning You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man Now lets try python with nodeps emerge -avu --nodeps =dev-lang/python-2.6.6-r2
Unfortunately build fails.

do we have an ebuild for portage that is satisfied with python we do have? Is there something older? Questions or comments? First upgrade, then mask if upgrade does not work, then -nodeps if mask is not enough.

What is the minimum of pkgconfig needed by pyhton? The last thing, if -nodeps also fails is to copy some newer binaries from installation CD. Next other development tools, python (it got updated already) , perl, gcc should be upgraded. Just a lot of patience.

emerge -avu --nodeps =sys-apps/portage-2.1.9.42
Another check halts progress again. ls /usr/portage/dev-lang/python/ | grep ebuild python-2.4.6.ebuild
python-2.5.4-r4.ebuild
python-2.6.6-r2.ebuild
python-2.6.7-r2.ebuild
python-2.7.1-r1.ebuild
python-2.7.2-r2.ebuild
python-2.7.2-r3.ebuild
python-3.1.3-r1.ebuild
python-3.1.4-r2.ebuild
python-3.1.4-r3.ebuild
python-3.2.2.ebuild
python-3.2-r2.ebuild
Nope. Quick look around in another, up to date machine reveals that ffi.h is supplied by dev-libs/libffi and actually virtual/libffi was one of the dependencies on python. Please feel free to contact us. © 2001–2016 Gentoo Foundation, Inc.

The Gentoo Name and Logo Usage Guidelines apply. rm /etc/portage/package.mask
Now we can install python with dependencies. the oldest ebuild for python 2.6 is 2.6.6-r2, which requires portage that we do not have. Newer portage wants to upgrade bash, which needs newer portage.

Look > in /var/tmp/portage/dev-lang/python-2.5.4-r4/image/ and check if this > library exists, and maybe try to do by hand what failed in the build log. > > Sorry, my time is up, emerge -avu --oneshot libtool
Libtool was the only one that did work actually and it brought some dependencies along. This takes care of upgrading portage. gentoo.org sites gentoo.org Wiki Bugs Forums Packages Planet Archives Sources Infra Status Archives Toggle navigation Home All Archives gentoo-user Gentoo Archives: gentoo-user From: Moritz Schlarb To: [email protected] Subject: [gentoo-user] Failed

I do use oneshot here as those packages are dependencies of something else anyway and I do not want to add them in my world file. One of the following masked packages is required to complete your request:
- dev-libs/popt-1.16-r1 (masked by: EAPI 3)
The current version of portage supports EAPI '2'.