gem install error zlib Wellsburg West Virginia

Address 621 Market St, Steubenville, OH 43952
Phone (740) 264-9661
Website Link
Hours

gem install error zlib Wellsburg, West Virginia

That worked for me. –Saurabh Hirani Jan 4 '12 at 5:00 add a comment| up vote 11 down vote try aptitude install zlib1g-dev Then go about your business. On Debian it means that zlib development packages have to be installed before one starts to compile the Ruby. Are the words "expression" and "term" interchangeable in programming language theory? It's not what I wanted; I wanted to know why I was getting the issue, but it's all sorted out.

How? I had a similar problem on OS X and updating Compress::Zlib (a Perl interface to ZLib) cured it - so I think an old version of ZLib (is now 1.2.3) may See http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0.6.0.tar.gz. If one writes to the /home/scoobydoo/.bashrc a line like: export PATH="/home/scoobydoo/ourcompiledruby/bin:/usr/bin" and restarts the bash shell by closing the terminal window and opening a new one, then by typing irb to

cd /usr/local/src/ruby make clean make make install cd ../rubygems ruby setup.rb gem install rails This made it work for me, but your mileage may vary. Browse other questions tagged 12.10 ruby rvm or ask your own question. Do you want to help us debug the posting issues ? < is the place to report it, thanks ! Why would a password requirement prohibit a number in the last character?

Fixes the issue on 1.9.2-p180/Red Hat 4.1.2-46 too. –adelarsq May 20 '11 at 16:41 This worked for Ubnutu 11.04/Ruby 1.9.2-p180. However, after doing a gem update --system, I now get a zlib error every time I try and do a gem install of anything. Hot Network Questions Compute the kangaroo sequence What's behind the word "size issues"? Or you could try the bash script found here.

Can cats leave scratch marks on cars? when trying to install rails Hot Network Questions How to use the binomial theorem to calculate binomials with a negative exponent How should I interpret "English is poor" review when I Does chilli get milder with cooking? rchennuri commented Dec 4, 2015 Thank you @Heshuge , solution is worked for me on Ubuntu 14.4 liuzxc commented Dec 22, 2015 thanks @Heshuge , it works for me!

but it did not help ~$ gem install Rails ERROR: Loading command: install (LoadError) cannot load such file -- zlib ERROR: While executing gem ... (NameError) uninitialized constant Gem::Commands::InstallCommand ~$ Is True or False? No idea what you just said. Note to mention I had installed gem before, and after recompile and install zlib, I don't recompile neither install gem (actually I don't knew how uninstall it because I don't found

share|improve this answer answered Feb 18 '11 at 16:52 Tryst 211 add a comment| up vote 1 down vote You could try to download the ruby enterprise deb package on the If you insist on going hi-tech, install Ruby 1.9.1. I did install Ruby before rvm and such. below is the console output I get when trying to install ruby gems. (along with the output from gem environment).

In the United States is racial, ethnic, or national preference an acceptable hiring practice for departments or companies in some situations? Second, I tried going to [ruby_dir]/ext/zlib and running Code: ruby extconf.rb checking for deflateReset() in -lz... If one wrote export PATH="/usr/bin:/home/scoobydoo/ourcompiledruby/bin" to the /home/scoobydoo/.bashrc ,then the /usr/bin/irb would get executed. The idea is that both, the library file and header files, are available in the system's "official" search path.

Tommy Pollák (tpollak) said on 2012-11-07: #4 Thanks, you are right. The time now is 03:50 AM. How exactly does the typical shell "fork bomb" calls itself twice? The same logic applies to libraries, except that the name of the environment variable is LD_LIBRARY_PATH The use of the LD_LIBRARY_PATH and PATH allow ordinary users, who do not have root

What are oxidation states used for? Word with the largest number of different phonetic vowel sounds In what atmospheric densities or pressures have aerobrakings been performed? Compute the kangaroo sequence What sense of "hack" is involved in "five hacks for using coffee filters"? share|improve this answer answered Apr 19 '11 at 14:44 Rod McLaughlin 6111 1 FYI - 'package' has been changed to 'pkg' in a more recent version of rvm.

wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0.6.0.tar.gz tar xvzf ruby-zlib-0.6.0.tar.gz cd ruby-zlib-0.6.0 ruby extconf.rb && make sudo make install Reinstall ruby gems from source Thanks anyway, guys. Tried everything else, and finally blue.sky.or.jp saved me. Log in / Register Ubunturubygems package Overview Code Bugs Blueprints Translations Answers Ruby gem command install does not find zlib Asked by Tommy Pollák on 2012-11-06 After reinstallation of Ubuntu 12.04 What (combination of) licenses is popular for public/shared proprietary software (“Feel free to contribute, but only we can make commercial use”)?

Is there a role with more responsibility? Is there any job that can't be automated? Done The following packages were automatically installed and are no longer required: linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae Use 'apt-get autoremove' to remove them. Setting up zlib1g-dev (1:1.2.3.4.dfsg-3ubuntu4) ...