gem mkmf error West Hartford Vermont

Address 46 Centerra Pkwy, Lebanon, NH 03766
Phone (603) 643-2598
Website Link
Hours

gem mkmf error West Hartford, Vermont

Enter your password to install the bundled RubyGems to your system: #####............................................................ Not the answer you're looking for? ERROR: Error installing sensu-plugin: ERROR: Failed to build gem native extension. /usr/bin/ruby1.9.1 extconf.rb /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError) from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from extconf.rb:1:in `

' How can I Thank you! –wasatchwizard Nov 14 '13 at 0:44 6 If you have installed your ruby with command sudo apt-get install ruby (without specifying the version) then you don't need to

Is it plausible for my creature to have similar IQ as humans? gcc package might be needed as well. If you are trying to install something like gem install pg you will also need to install the lib libpq-dev (sudo apt-get install libpq-dev). Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/sys-proctable-0.7.3 for inspection. To get around this you will need to install ruby1.8-dev (or ruby1.6-dev or whatever version of ruby you're running) to get

Chebyshev Rotation Create a wire coil With the passing of Thai King Bhumibol, are there any customs/etiquette as a traveler I should be aware of? Nevermind I had to update ruby. –obesechicken13 Mar 17 '14 at 15:59 1 I've installed ruby-all-dev, it will probably work for all versions. –jcubic Jul 7 '14 at 13:38 | You don't need to update. asked 2 years ago viewed 68130 times active 2 months ago Linked 0 ruby gem not install 178 gem install: Failed to build gem native extension (can't find header files) 16

You signed in with another tab or window. Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. I just spent about 45mins compiling ruby 2 and trying to install mailcatcher try & error style. Join them; it only takes a minute: Sign up `require': no such file to load — mkmf (LoadError) up vote 504 down vote favorite 76 I was trying to install rails

I have ruby 1.8.7. Create a wire coil 5008 out of the box How much is "a ladleful"? awaistune commented Apr 14, 2016 sudo apt-get install ruby-dev is working for me too. Thanks!

This could take a while... In my case, I was scratching my head because my build was working fine until I upgraded to El Capitan. –bruce1337 Dec 9 '15 at 0:11 add a comment| up vote How should I interpret "English is poor" review when I used a language check service before submission? asked 5 years ago viewed 155127 times active 2 months ago Linked 8 nokogiri will not install - ERROR: Failed to build gem native extension 0 Error in “gem install mathematical”

This could take a while... I am doing that (but still have the issue of this mkmf error when installing rails) –thesecretmaster May 28 at 16:38 add a comment| Your Answer draft saved draft discarded Reload to refresh your session. Entering the command ruby --version gets me this: ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux] Should I update to the latest version of Ruby?

Faison Faison commented Jul 23, 2014 Marking the issue as closed. how can you tell if the engine is not brand new? When casting a cube spell on a hex grid do you pick a honeycomb for origin or an intersection for origin? Filed under linux, programming, ruby.

I think instead of ruby-dev its ruby-devel. This might do it for you: https://github.com/rbenv/rbenv kkrieger85 commented Mar 30, 2016 sudo apt-get install ruby-dev is working for me too. This could take a while... Why do train companies require two hours to deliver your ticket to the machine?

Results logged to /var/lib/gems/1.9.1/gems/json-1.8.1/ext/json/ext/generator/gem_make.out [email protected]:~/mailcatcher$ cat /var/lib/gems/1.9.1/gems/eventmachine-1.0.3/ext/gem_make.out /usr/bin/ruby1.9.1 extconf.rb sunilkr commented Jul 4, 2014 You have gcc? This could take a while... This has helped me point me in the direction of using RVM to help install ruby on rails on Linux Mint kenorb commented Nov 1, 2015 I can confirm that installing Then don't you already have the ruby version you need? –thesecretmaster May 28 at 16:36 add a comment| up vote 33 down vote I also needed build-essential installed: sudo apt-get install

How do I say "best practice" in Esperanto? We recommend upgrading to the latest Safari, Google Chrome, or Firefox. justinwsmith commented Feb 9, 2014 Shellcat-Zero, I made a few updates to "extconf.rb". worked for my install Mongify on Centos7 –Silvio Lucena Junior Jan 25 at 17:21 You can add sudo zypper install ruby-devel for openSUSE –superbob Feb 9 at 16:09

Not sure if mismatching versions like that is going to cause me any headache later, but it should be noted that rails installed correctly using a slight alteration of the officially Why does argv include the program name? I'm setting up my environment through a proxy. ERROR: Error installing rails: ERROR: Failed to build gem native extension. /usr/bin/ruby1.8 extconf.rb extconf.rb:36:in `require': no such file to load -- mkmf (LoadError) from extconf.rb:36 Gem files will remain installed in

Thanks for the help! The second system is the exact same OS with no GPGPUs on it. Tags fixes tech opensolaris sysadmin puppet October 2006 S M T W T F S « Sep Nov » 1234567 891011121314 15161718192021 22232425262728 293031 Archives January 2010 September 2009