freeswitch socket connection error Santa Elena Texas

Address Harlingen, TX 78550
Phone (956) 357-7283
Website Link
Hours

freeswitch socket connection error Santa Elena, Texas

Bote From: Richard Mace Sent: Friday, 06 March, 2015 14:34 Subject: [Freeswitch-users] fs_cli will not connect on Fresh install on Debian Hi All, I did a fresh install of both Debian Its strange as it's only happened within the last month, as I built a system recently that worked fine out of the box. Reconnect if disconnected? -d, --debug=level?????????????? If it>> is it's probably an ACL problem, if it isn't then it's probably a>> problem with event_socket.conf.xml>> >> -Steve>>>> On 28 February 2011 00:53, deniro>> <[hidden email]> wrote: >>

I tested again. On Fri, Mar 6, 2015 at 3:33 PM, Richard Mace wrote: Hi, Sorry, I should have clarified that this is running locally on the machine running FreeSWITCH. If it is it's probably an ACL problem, if it isn't then it's probably a problem with event_socket.conf.xml -Steve On 28 February 2011 00:53, deniro <[hidden email]> wrote: > What would Debug Level (0 - 7)? -t, --timeout??????????????????

FreeSWITCH Version 1.1.beta1 (git-c41a16d 2012-04-0514-28-01 -0500)[root at localhost freeswitch]# ./fs_cli[ERROR] fs_cli.c:1320 main() Error Connecting [Socket Connection Error]Usage: ./fs_cli [-H ] [-P ] [-p ] [-d ] [-xcommand] [-t ] [profile]? -?,-h If there's an error that'll hopefully show it up if it's not making it to the log file. log_uuid_short_length : 0); 1253 } else if(!strcasecmp(var, "log-uuid-length")) { 1254 int i; 1255 if ((i = atoi(val)) > -1) { 1256 profiles[pcount-1].log_uuid_length = i; 1257 } 1258 } else if(!strcasecmp(var, "quiet")) Is mod_event_socket loading before or after mod_xml_curl?

Board index The team • Delete all board cookies • All times are UTC Powered by phpBB Forum Software © phpBB Group [email protected] Discussion: fs_cli error (too old to reply) Jagadish Chances are mod_xml_curl is loading first, so it's trying to read event_socket.conf.xml and/or acl.conf.xml through xml_curl and either getting a different config to your previous local copy or the ACLs are Thanks Richard _________________________________________________________________________ Professional FreeSWITCH Consulting Services: [email protected] http://www.freeswitchsolutions.com Official FreeSWITCH Sites http://www.freeswitch.org http://confluence.freeswitch.org http://www.cluecon.com FreeSWITCH-users mailing list [email protected] http://lists.freeswitch.org/mailman/listinfo/freeswitch-users UNSUBSCRIBE: http://lists.freeswitch.org/mailman/options/freeswitch-users http://www.freeswitch.org _________________________________________________________________________ Professional FreeSWITCH Consulting Services: [email protected] http://www.freeswitchsolutions.com Official Try this: configure --prefix=/opt/freeswitch --without-libcurl make update-clean make install On Mon, Feb 28, 2011 at 5:37 PM, deniro <[hidden email]> wrote: > > Anthony > Thanks for the quick response I

If it is it's probably an ACL problem, if it isn't then it's probably a problem with event_socket.conf.xml -Steve On 28 February 2011 00:53, deniro <[hidden email]> wrote: > What user at domain? -p, --password=password???????? If it>> >> is it's probably an ACL problem, if it isn't then it's probably a >> >> problem with event_socket.conf.xml>> >>>> >> -Steve>> >>>> >> On 28 February 2011 00:53, handle->last_event->body : ""); 807 esl_event_serialize(handle->last_event, &s, ESL_FALSE); 808 output_printf("RECV EVENT\n%s\n", s); 809 redisplay(); 810 free(s); 811 } 812 } 813 } 814 if (warn_stop) { 815 if (aok) { 816 clear_line();

Tweet Pin It Get The FreeSWITCH Advantage™ Get the Books! Bote From: Richard Mace Sent: Tuesday, 10 March, 2015 02:20 To: FreeSWITCH Users Help Subject: Re: [Freeswitch-users] fs_cli will not connect on Fresh install on Debian Hi, Is there an fs_cli Unless it loads that module it won't listen on 8021. Execute Command and Exit? -l, --loglevel=command?????????

Chances are >> mod_xml_curl is loading first, so it's trying to read >> event_socket.conf.xml and/or acl.conf.xml through xml_curl and either >> getting a different config to your previous local copy or If itis it's probably an ACL problem, if it isn't then it's probably a problem with event_socket.conf.xml-Steve On 28 February 2011 00:53, deniro <[hidden email]> wrote:> What would be possible reasons If it > >> >> is it's probably an ACL problem, if it isn't then it's probably a > >> >> problem with event_socket.conf.xml > >> >> > >> >> -Steve To connect from a remote machine put a valid routable interface address (although I have 0.0.0.0 in mine) in conf/autoload_configs/event_socket.conf.xml and change the password and maybe even the port depending on

You should look at adding the critical="true" attribute to all the tags in modules.conf.xml which you want to be sure are loaded. Host to connect? -P, --port=port???????????????? On Mon, Feb 28, 2011 at 5:18 PM, deniro <[hidden email]> wrote: > I put the log in pastebin > freeswitch.log only when starting freeswitch (after stop) > > http://pastebin.freeswitch.org/15502> thx > What does "netstat -anlp | grep :8021" from the linux cli show you?Does it show that freeswitch is actually listening on the port?

Chances are >> >> mod_xml_curl is loading first, so it's trying to read >> >> event_socket.conf.xml and/or acl.conf.xml through xml_curl and either >> >> getting a different config to your previous If it is trying to, perhaps start freeswitch in the foreground (-c option) and then (re)load the module once it's running. Nothing from netstat means nothing's listening, so trying to connect using fs_cli won't do anything. -Steve On 28 February 2011 22:40, deniro <[hidden email]> wrote: > Checked the log > Nothing Core Team Down For Maintenance This section of FreeSWITCH.org is currently offline for maintenance.

Some look like they're missing (no such file or directory) and others haven't been built right (undefined symbols). What does "netstat -anlp | grep :8021" from the linux cli show you? Home Pro Support Commercial Modules Download Docs Source Features Lists Issues PasteBin Videos Live Chat HELP US! Usage Information? -H, --host=hostname????????????

All rights reserved. Just restored from tar backup and I am able to run fs_cli  without any problem my firewall settings are the same before and after tar restore.   /opt# tar -xvf freeswitch.tar.feb26 /etc/init.d/freeswitch If it>> >> is it's probably an ACL problem, if it isn't then it's probably a >> >> problem with event_socket.conf.xml>> >>>> >> -Steve>> >>>> >> On 28 February 2011 00:53, Some look like they're missing (no such file or directory) and others haven't been built right (undefined symbols).Here are a few of the important lines from your log:2011-02-28 18:12:21.910738 [CRIT] switch_loadable_module.c:882

Just restored from tar backup and I am able to run fs_cli > without any problem > my firewall settings are the same before and after tar restore. > > /opt# tar If >> >> >> it >> >> >> is it's probably an ACL problem, if it isn't then it's probably a >> >> >> problem with event_socket.conf.xml >> >> >> >> len : (int)strlen(cmd); 295 for (i = 0; i < l; i++) { 296 cmd[--iCmdBuffer] = 0; 297 } 298 iCmdCursor = (int)strlen(cmd); 299 printf("%s", prompt); 300 GetConsoleScreenBufferInfo(hOut, &info); 301 orgPosition Is mod_event_socket loading before or after mod_xml_curl?

Chances are>> >> mod_xml_curl is loading first, so it's trying to read >> >> event_socket.conf.xml and/or acl.conf.xml through xml_curl and either>> >> getting a different config to your previous local copy Did you recompile when trying to add mod_xml_curl? If it >> >> is it's probably an ACL problem, if it isn't then it's probably a >> >> problem with event_socket.conf.xml >> >> >> >> -Steve >> >> >> >> If itis it's probably an ACL problem, if it isn't then it's probably a problem with event_socket.conf.xml-Steve On 28 February 2011 00:53, deniro <[hidden email]> wrote:> What would be possible

If a modulefails to load without that tag FS will continue to run anyway, with that tag it'll refuse to start so you'll know instantly something iswrong.Most of your modules aren't Does it show that freeswitch is actually listening on the port? running fs 106 on ubuntu 10.04 server   /opt/freeswitch/bin/fs_cli -H xxx.xxx.xxx.xxx -P 8021[ERROR] libs/esl/fs_cli.c:1206 main() Error Connecting [Socket Connection Error] was working fine before I installed  mod_xml_cdr configure --prefix=/opt/freeswitch --without-libcurl make mod_xml_cdr-install Disable logging? -r, --retry????????????????????

Chances are mod_xml_curl is loading first, so it's trying to readevent_socket.conf.xml and/or acl.conf.xml through xml_curl and eithergetting a different config to your previous local copy or the ACLs aredifferent. Just restored from tar backup and I am able to run fs_cli without any problem my firewall settings are the same before and after tar restore. /opt# tar -xvf freeswitch.tar.feb26 /etc/init.d/freeswitch Tell us about it. Timeout for API commands (in miliseconds)_________________________________________________________________________consulting at freeswitch.orghttp://www.freeswitchsolutions.comFreeSWITCH-powered IP PBX: The CudaTel Communication Serverhttp://www.cudatel.comOfficial FreeSWITCH Siteshttp://www.freeswitch.orghttp://wiki.freeswitch.orghttp://www.cluecon.comFreeSWITCH-users mailing listFreeSWITCH-users at lists.freeswitch.orghttp://lists.freeswitch.org/mailman/listinfo/freeswitch-usersUNSUBSCRIBE:http://lists.freeswitch.org/mailman/options/freeswitch-usershttp://www.freeswitch.org-------------- next part --------------An HTML attachment was scrubbed...URL: http://lists.freeswitch.org/pipermail/freeswitch-users/attachments/20120405/ea49614a/attachment.html Anton Kvashenkin 2012-04-06

Is mod_event_socket loading before or after mod_xml_curl? Mitt kontoSökMapsYouTubePlayNyheterGmailDriveKalenderGoogle+ÖversättFotonMerWalletDokumentBloggerKontakterHangoutsÄnnu mer från GoogleLogga inDolda fältSök efter grupper eller meddelanden   Search for:Search Want your own MarkMail? If a module fails to load without that tag FS will continue to run anyway, with that tag it'll refuse to start so you'll know instantly something is wrong. Chances are >> >> mod_xml_curl is loading first, so it's trying to read >> >> event_socket.conf.xml and/or acl.conf.xml through xml_curl and either >> >> getting a different config to your previous

Hello Nobody Logout Sign In or Sign Up (Why?) HomeRefine Search    Messages per Month     Sort by Relevance Date, Forward Date, Backward Start a set with this searchInclude this search in one of What does "netstat -anlp | grep :8021" from the linux cli show you?