extra_cflags error Fall Branch Tennessee

Address 602 N Roan St, Johnson City, TN 37601
Phone (423) 975-6840
Website Link
Hours

extra_cflags error Fall Branch, Tennessee

The time now is 05:58 AM. The easist answer is to upgrade the kernel to 2.2.26, but without a LAN that might be tricky. To try building the driver, type: make -j1 and see what happens. Including some extra optimization flags that may or may not be valid to the specific kernel configuration in question.

Fix it to use EXTRA_CFLAGS) endif endif include scripts/Makefile.lib Show Gregory Hinton Nietsky added a comment - 22/Dec/07 11:06 AM From scripts/Makefile.build (Linux source) make KBUILD_NOPEDANTIC=1 all modules install-modules If the If you are unsure which runlevel to choose, you could place links in all seven. in a console... Join them; it only takes a minute: Sign up Kernel module compilation and KBUILD_NOPEDANTIC up vote 12 down vote favorite 3 I've noticed that recent kernels (starting from 2.16.24?) don't like

We can't just change the build commands there. issues.asterisk.org runs on a server provided by Digium, Inc. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Might be that my kernel is too new, who knows...

Ubuntu Logo, Ubuntu and Canonical © Canonical Ltd. You will need to get the packages network-manager-vpnc and vpnc from the Ubuntu repositories using either the Synaptic Package Manager or apt-get. That was with Line 8 comented out #CFLAGS+=-DSTANDALONE_ZAPATA -DBUILDING_TONEZONE Show Ken Myers added a comment - 21/Dec/07 9:53 PM sorry, got trunicated.. What is the path to the file where I will need to change that???

True! Apply the changes and now try to connect to the VPN by returning to Network Manager in the task bar and selecting your newly created VPN.Stanfprd _Public_VPN .pcf configuration file It I tried... If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Any help is appreciated thanks a lot Try setting the variable KBUILD_NOPEDANTIC to 1 before running make 1 members found this post helpful. SVA GrapefruiTgirl View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by GrapefruiTgirl 06-19-2009, 09:55 AM #5 Invisible-Man Member Registered: Jun 2009 more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

Thanks for your time. –Farrukh Arshad Dec 6 '12 at 13:51 The output before that “Kernel configuration is invalid” message might be relevant. Love is very patient and kind, never jealous or envious, never boastful or proud, never haughty or selfish or rude. It can't be an Ubuntu-specific driver, as I'm using Slackware. By installing this product you agree that you have read the license.txt file (The VPN Client license) and will comply with its terms.

Sasha PS - Another option is to change the CFLAGS = to CFLAGS += so it will append to the existing CFLAGS environment variable. working with some testing here with new 8.04 LTS, and I needed the libsnmp15 stuff) This is a clean install of 8.04 Alpha, using kernel 2.6.24-2. (A bug in alpha does make[1]: *** [_module_/home/operatorr/drivers/e100-3.5.17/src] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-2.6.28-11-server' make: *** [default] Error 2 I've googled a bit and searched the forums, but nothing matches this exactly. To have the client start at boot for runlevel 2, issue the command: ln -s /etc/init.d/vpnclient_init /etc/rc2.d/S85vpnclient_init To have the client run at a different runlevel boot simply replace rc2 in

Tracing some relevant points (but not all, because that is left as an exercise to the reader ;-) ) shows the following: EXTRA_CFLAGS can still be used, according to scripts/Makefile.lib 1 Michael Lagemann (mischi) wrote on 2008-04-29: #6 Thanks, that worked for me. I just ran the routine again on a freshly unpacked driver source, and the patch works cleanly for me. If I replace the KCFLAGS var [which I added there] with EXTRA_CFLAGS it causes some build errors: ======================================================================================================================== In file included from include/linux/kernel.h:7:0, from /home/sandu/work/openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openvswitch-2.3.0/datapath/linux/compat/include/linux/kernel.h:4, from include/linux/skbuff.h:17, from /home/sandu/work/openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openvswitch-2.3.0/datapath/linux/compat/include/linux/skbuff.h:4, from /home/sandu/work/openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openvswitch-2.3.0/datapath/linux/actions.c:21:

A better way to evaluate a certain determinant Why can't I find Phase to phase voltage like this Is there any job that can't be automated? Duplicate of bug #273727 Remove Convert to a question Link a related branch Link to CVE You are not directly subscribed to this bug's notifications. Alsa /usr/bin/make -C /usr/src/linux-headers-2.6.26 SUBDIRS=/usr/src/modules/alsa-driver O=/usr/src/linux-headers-2.6.26 CPP="gcc-4.1 -E" CC="gcc-4.1" modules make[3]: Entering directory `/usr/src/linux-headers-2.6.26' /usr/src/linux-headers-2.6.26/arch/x86/Makefile:41: /usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu: No such file or directory and cdfs make -C /usr/src/linux-headers-2.6.26 SUBDIRS=/usr/src/modules/cdfs/2.6 modules make[3]: Entering directory Quote: Originally Posted by Uncle_Theodore Try setting the variable KBUILD_NOPEDANTIC to 1 before running make Where is that located at???

Also, You may use status, restart or reload in addition to start and stop. I figured that the name "KCFLAGS" would not collide with other build vars, and we could set it at the top-level build rule. Regards, Farrukh Arshad. If it successfully finds the server it will either ask or verify your passwords.

Sasha GrapefruiTgirl View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by GrapefruiTgirl 07-02-2009, 09:11 AM #14 Invisible-Man Member Registered: Jun 2009 If you'd like to contribute content, let us know. This has never been documented and was a bad practice. I had the exact same problem, and managed to work it out, so here is the full solution: Asus P5Q motherboard, needs atl1e driver for Attansic/Atheros LAN, kernel 2.6.24 fc8.

It used to suck (e.g. 7.04), but it has improved greatly in recent releases. I am going to edit my post above, where I put the patch file for you, and re-paste the patch in there. Not the answer you're looking for?