error* radeon ring test failed Armour South Dakota

Address 318 N Main St, Mitchell, SD 57301
Phone (605) 996-4899
Website Link http://www.officeadv.com
Hours

error* radeon ring test failed Armour, South Dakota

Last edited by vanquish (2014-09-05 17:57:05) Offline #2 2014-08-30 12:14:53 clfarron4 Member From: London, UK Registered: 2013-06-28 Posts: 2,162 Website Re: [SOLVED][ATI] Driver and/or Kernel Issue? I would suggest trying a newer version of mesa. Looking at the logs, I have had a fair number of GPU faults which I did not notice, briefly for a few seconds about 4 hours before an extended period of Bug799681 - No GPU acceleration - drm ring test failed Summary: No GPU acceleration - drm ring test failed Status: CLOSED WORKSFORME Aliases: None Product: Fedora Classification: Fedora Component: xorg-x11-drv-ati (Show

busy on resume, I guess). Though it looks like I upgraded from kernel 3.17.2-200 to 3.17.3-200 yesterday and have not needed to suspend during that time. P.S. Seeing as the patch does not work/insufficient, and my best experience so far is 10.2.9 (lasted 3 weeks, without the patch), my worst experience is 10.3.3 (less than a day), and

Mar 24 15:15:32 manji kernel: radeon 0000:00:01.0: WB enabled Mar 24 15:15:32 manji kernel: radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff8804099a5c00 Mar 24 or after an two hours). Please report the Xv problem at https://bugs.freedesktop.org/enter_bug.cgi?product=xorg , component Driver/glamor. Comment 21 Michel Dänzer 2014-12-17 02:19:17 UTC If there really is a significant difference in stability between Mesa 10.2.y and 10.3.y, it would be interesting if you could isolate which change

NOTE: These are the steps that I think they solved my problem; because I was struggling for 3 hours and doing many things. Bad idea! Comment 24 Hin-Tak Leung 2014-12-18 19:40:15 UTC I had a quick look about 10.2.x vs 10.3.x (specifically, just doing "git log mesa-10.2.8..mesa-10.3.3 | grep '^commit' | wc -l" and vice versa), Comment 23 Michel Dänzer 2014-12-18 06:03:54 UTC (In reply to Hin-Tak Leung from comment #22) > My crash-free days with 10.3.x/10.4.0 are measured in days if not hours, but > with

Sorry, I've forgotten it.00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06) 00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller Let me know if there are other measures I can take to help resolving this bug. Aug 29 10:25:57 localhost kernel: radeon 0000:01:00.0: ib ring test failed (-35). I was away from the computer when the radeon dri driver crashed; I left a fair number of firefox windows on/tab, some of them may have videos (from BBC news web

Last edited by vanquish (2014-09-05 17:56:45) Offline Pages: 1 Index »Kernel & Hardware »[SOLVED][ATI] Driver and/or Kernel Issue? I've cut the log.Please help me to fix this. I had to do a hard reset every time. If needed, I can provide ssh access to the machine.

Thanks, Rui Comment 6 Dominik Klementowski 2016-05-08 10:24:09 UTC Created attachment 123548 [details] dmesg | grep radeon I use Lenovo Z51-70 laptop with Intel HD5500 and discrete Radeon R9 M375. Note You need to log in before you can comment on or make changes to this bug. Comment 2 Rui Salvaterra 2016-04-23 10:50:43 UTC Adding Benjamin Herrenschmidt to the cc list, for the original [1] patch. [1] https://lists.ozlabs.org/pipermail/linuxppc-dev/2010-August/085302.html Comment 3 Rui Salvaterra 2016-04-24 12:06:57 UTC *** Bug 89886 Aug 29 10:25:59 localhost kernel: [drm] ib test on ring 0 succeeded in 0 usecs Aug 29 10:25:59 localhost kernel: [drm] ib test on ring 1 succeeded in 0 usecs Aug

What are "desires of the flesh"? Why does argv include the program name? I'm also on Ubuntu 14.04. Maybe I'm able to purge Windows from this machine.

I would suggest > > trying a newer version of mesa. > > How recent should I try? It can isolate a change with the minimum number of tests required (approximately log2 of the number of commits between the known good and bad). > It would be easier if I even installed the driver I downloaded from ATI website (which was working fine in my previous Ubuntu 12.04), but it didn't work either. Mar 24 15:15:33 manji kernel: [drm:radeon_dp_link_train] *ERROR* displayport link status failed Mar 24 15:15:33 manji kernel: [drm:radeon_dp_link_train] *ERROR* clock recovery failed Mar 24 15:15:33 manji kernel: [drm] ib test on ring

apparently after updating mesa(to try next) the new version is 10.6.0_devel.67962-1 but the old one(with the above error) was 10.6.0_devel.68990-1 using manjaro linux. Comment 2 Hin-Tak Leung 2014-10-08 12:28:38 UTC The patches listed above don't fix the problem. With kernel 3.18.9-200.fc21.x86_64, besides GPU lock up, the kernel also oops'ed. This bug is most certainly caused by some kind of interaction between the card and the IOMMU (bypass).

We will review this issue again once you've had a chance to attach this information. My problem was solved by this approach. ( system configuration -: opensuse13.1, kernel version was 3.11.6-5, graphic card used- amd radeon hd4500, ) In /etc/default/grub change splash=silent to splash=0 comment out Like I wrote before, I'm willing to provide ssh access to the machine (Power Mac G5), if the bug is hard to reproduce. So that's 10 days since last crash.

But I've only recently(1-2days) upgraded to kernel 4, from 3.19. I am going back to 10.2.9 patched, until the next mesa that's not 10.3.5 and 10.4.0... You will have to register before you can post in the forums. (Be aware the forums do not accept user names with a dash "-") Also, logging in lets you avoid Pages: 1 #1 2014-08-30 10:23:14 vanquish Member Registered: 2013-12-28 Posts: 43 [SOLVED][ATI] Driver and/or Kernel Issue?

Comment 25 Michel Dänzer 2014-12-19 03:23:55 UTC (In reply to Hin-Tak Leung from comment #24) > [...] which is still a big bunch to look at what made 10.3.x > unstable. This time it happened when I was running mplayer - with -vo xv, I think. (in addition to firefox). I'm beginning to suspect a hardware fault, but I'm going to try disabling DRM and test. I'll ask again.clfarron4 wrote:vanquish wrote:System specs:GPU ATI R9 270xCPU Intel Haswell i5-4440Board MSI H87-G43RAM 8 GB Mushkin DDR-3/1333Samsung SSD 830What's the output of lspci?