gentoo error xml parser perl module is required for intltool Wiscasset Maine

Address 126 Western Ave Ste 236, Augusta, ME 04330
Phone (207) 441-2108
Website Link https://www.5sds.net
Hours

gentoo error xml parser perl module is required for intltool Wiscasset, Maine

expat has been updated. Editing those .la files or creating those symlinks are proper solutions. In short, a package A may declare a subslot, and a package B that depends on A may declare "rebuild me if A changes subslot". That would work also.

Dale :-) :-) -- [hidden email] mailing list Nagatoro Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: Re: checking configure: error: XML::Parser perl module is required for intltool [In reply to] > On a second machine I tried: > revdep-rebuild -X --library=libexpat.so.0 > > it recompiles a lot of packages ewarn "Please note that the soname of the library changed!" ewarn "If you are upgrading from a previous version you need" ewarn "to fix dynamic linking inconsistencies by executing:" ewarn "revdep-rebuild Gentoo is a trademark of the Gentoo Foundation, Inc.

configure: error: XML::Parser perl module is required for intltool Classic List Threaded ♦ ♦ Locked 41 messages 123 Mark Knecht Reply | Threaded Open this post in threaded view ♦ ♦ Another solution if you don't need gcj anyway > is to disable that use flag.. > Ah, OK, that's different. configure: error: XML::Parser perl module is required for intltool [In reply to] >>> emerge gnome fails. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.

I had made a mistake in making package. That's an > > > > improvement. > > > > > > No, it's really not.. Password Linux - Software This forum is for Software issues. Terms Privacy Opt Out Choices Advertise Get latest updates about Open Source Projects, Conferences and News.

I didn't want to do that as I don't know what they do. (Please remember, I am a DUMMY. Or > > > post the output from the stable version of revdep-rebuild --ignore. > > > > I did read it. We've added the following instructions to the perl-cleaner output, which may help cleaning up the most frequent difficulties: * perl-cleaner is stopping here:* Fix the problem and start perl-cleaner again.* * configure: error: XML::Parser perl module is required for intltool It is a Gentoo issue.

I tried the ~x86 version of gentoolkit and revdep-rebuild does not generate the requirement to rebuild gcc. Is this a bug since several have ran into this? No, thanks Gentoo › gentoo-user Search everywhere only in this topic Advanced Search checking for XML::Parser... Updated all the kde-3.5.7 packages, revdep-rebuild the libraries it asked me to and now when I run revdep-rebuild, it wants to downgrade all this lot: =================================================== All prepared.

done! [ebuild U ] gnome-base/gnome-vfs-2.18.1 [2.16.3-r1] USE="hal ipv6 ssl -avahi -debug -doc -gnutls -samba" 0 kB and the failure: checking if libtool supports shared libraries... Portage will try to figure out how to do this, but blockers and general weirdness may happen. LinuxQuestions.org > Forums > Linux Forums > Linux - Software XML::Parser perl module is required User Name Remember Me? configure: error: XML::Parser perl module is required for intltool !!!

I don't know if this a coLinux issue or a Gentoo issue. configure: error: XML::Parser perl module is required for intltool [In reply to] When I was upgrading on one of the machines, I did encounter this same error on a couple gnome-related You need to upgrade some more packages (hopfully). -- Naga -- gentoo-user [at] gentoo mailing list michaelkintzios at gmail Aug15,2007,3:48AM Post #38 of 41 (2300 views) Permalink Re: Re: checking for XML::Parser... Well...

yes checking whether to build shared libraries... This I fixed by emerging gettext with USE='-emacs'. > > Good. > > [SNIP] >> It attempts to emerge x11-libs/gtk+-2.10.13 but that needs pango > [SNIP] >> Pango fails to emerge configure: error: XML::Parser perl module is required for intltool On Sunday 12 August 2007 18.50.24 Dale wrote: > I copied the command from what I was given by portage. On mine, it didn't fix anything that I could see.

Call stack: ebuild.sh, line 1632: Called dyn_compile ebuild.sh, line 983: Called qa_call 'src_compile' ebuild.sh, line 44: Called src_compile ebuild.sh, line 1322: Called gnome2_src_compile I suspect I'll just go back to stable and join the hordes looking for a fix to the stable version of revdep-rebuild.) Anyway, thanks for the help. During the rebuild, the installation is run by the updated Perl, which makes the files go into the new, now correct path. Your help was greatly appreciated.

and it's a boy. There are several bugs open against it. Lerner - 2005-05-07 14:43:58 During the last couple of weeks, I am getting a persistent error when running emerge -uDv world in coLinux (stable-0.6.3-pre10-hn1). All done.

geniarse View Public Profile View LQ Blog View Review Entries View HCL Entries Visit geniarse's homepage! I had to choose the URL from the list Reply ↓ Leave a Reply Cancel reply Your email address will not be published. My count is 61 packages altogether today (wry smile), incl many which have updates, but are not related to the Expat problem. -- ========================,,============================================ SUPPORT ___________//___, Philip Webb : Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community.

It seemed that the stable revdep-rebuild solution was to start editing system files. Any thoughts? > > checking for perl... /usr/bin/perl > checking for XML::Parser... Find More Posts by BigNate 09-26-2004, 05:44 AM #8 donbellioni Member Registered: Mar 2004 Location: UK Distribution: Slackware 10 Posts: 137 Rep: BigNate, i was having the same problem Most of the re-installs were due to expat lib as well.

I get quite tired, and frankly > > > do not understand, why gcc itself should be on this list so often, > > > > Maybe because of this: > configure: error: XML::Parser perl module is required for intltool !!! Is this a bug since several have ran into this? By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features.

This I fixed by emerging gettext with USE='-emacs'. If you know anything about it I would appreciate you tell me. done! [ebuild UD] kde-base/kdelibs-3.5.5-r10 [3.5.7-r2] USE="acl alsa cups fam ker beros spell ssl%* tiff -arts -avahi -debug -doc -jpeg2k -kdeenablefinal -kdehidd envisibility -legacyssl -lua -openexr -utempter -xinerama -zeroconf% (-branding% )" LINGUAS="-he%" However, on my other machine, the upgrade of the same packages was seamless, and the list of packages to upgrade were somewhat different, although the two machines are configured pretty much

I've plotted the current EAPI distribution of ebuilds using perl-module.eclass in a pie chart for illustration... Both have their merits, they just don't play very well with each other... Latest posts by Eugen Mihailescu (see all) Converting MySQL to PostgreSQL - May 11, 2016 Use Composer without SSH access - May 11, 2016 How to rotate even odd scanned PDF So, what is it about?

Thanks Naga, I should have said that a --update world did not pick these up. However that usually only happens when you are trying to get some obscure beta module and the author has written an incomplete or distro centric make file. Could some of the packages have been out of sync on the different mirrors and cause this messy upgrade procedure to happen on some machines? -- gentoo-user [at] gentoo mailing list Also, I have some Gnome stuff as a dependency but I use KDE. > > Dale And another problem I had was with svn unable to find libexpat.so.0.