error x11/xlib.h no such file or directory rvm Alviso California

Address 92 Bonaventura Dr, San Jose, CA 95134
Phone (408) 894-1230
Website Link
Hours

error x11/xlib.h no such file or directory rvm Alviso, California

I will make a bugfix release soon Sign up for free to join this conversation on GitHub. I am dead in the water. by David Sommers. Find Tcl/Tk libraries.

WARNING: found "/System/Library/Frameworks/Tcl.framework/Versions/Current/tclConfig.sh", but it WITH nativethread-support under ruby WITHOUT nativethread-support. Resolving the problem is easy. Post Loading... What am I doing wrong?

For the record though, I'm not Wayne though :) matherton commented Nov 24, 2012 Sorry and cheers for the help Richo - still having the same problem though even though I Ruby enVironment Manager member richo commented Nov 24, 2012 No problems- It happens to the best of us. Unix & Linux Stack Exchange works best with JavaScript enabled ./databyte Upgrading to Mountain Lion So I finally got around to upgrading to Mountain Lion. add a comment| 2 Answers 2 active oldest votes up vote 16 down vote try rvm reinstall 1.8.7 --without-tcl --without-tk but still your problem might to be related to gcc-4.2 ->

Now let’s install XQuartz and then reinstall ruby but also explicity set X11’s include path: $ export CPPFLAGS=-I/opt/X11/include $ CC=/usr/local/bin/gcc-4.2 rvm reinstall 1.8.7 Removing /Users/databyte/.rvm/src/ruby-1.8.7-p370... /Users/databyte/.rvm/rubies/ruby-1.8.7-p370 has already been removed. So how exactly do I read rvm requirements? Were you able to get it to work? I've committed a fix right now, and Gosu 0.9.3 will not try to #include

Tweet me @databyte. By Amulya Shahi Date 2015-07-15 05:05 Hey thanks for correcting that for me.. Does chilli get milder with cooking? It fails when compiling.

This could take a while...ERROR: Error installing gosu: ERROR: Failed to build gem native extension. /home/amulya/.rvm/rubies/ruby-2.2.1/bin/ruby -r ./siteconf20150714-5173-1680r2l.rb extconf.rbThe Gosu gem requires some libraries to be installed system-wide.See the following House of Santa Claus Why does argv include the program name? arnab commented Jan 9, 2013 For anyone stumbling upon this, I installed XQuartz, tcl, and tk and then followed this SO answer to successfully install ree. They're more worried about security and stability that features and/or recency.

You can brew upgrade ruby-build --HEAD now to get the fix. Not the answer you're looking for? It looks like a broken source link in another gem that depends on faster_xml_simple.>: gem install faster_xml_simpleThen install Gosu and the currently maintained extensions. This could take a while...ERROR: Error installing gosu: ERROR: Failed to build gem native extension. /home/amulya/.rvm/rubies/ruby-2.2.0/bin/ruby -r ./siteconf20150712-1819-nvwpk3.rb extconf.rbThe Gosu gem requires some libraries to be installed system-wide.See the following

Having ruby 2+ is ok, relax you'll probably want it eventually. How do I answer why I want to join a smaller company given I have worked at larger ones? or am I missing something? (I'm missing many things) but what specifically am I missing? nochecking for main() in -lopenal...

Seems liks the CONFIGURE_OPTS= should be correct. Let’s try to install ruby-1.8.7 with rvm: $ rvm install ruby-1.8.7-p370 No binary rubies available for: osx/10.8/x86_64/ruby-1.8.7-p370. I can't even remember a time where I used Tcl/Tk from Ruby even once … On 16/11/2012 10:54, Parker Moore wrote: |rvm reinstall 1.8.7 --without-tcl --without-tk| worked like a charm for Ruby enVironment Manager member richo commented Nov 17, 2012 Tcl is dead, unless you're wrapping some massively antiquated software, using Tcl/tk is a pretty good sign you're Doing It Wrong Tm.

Still no joy. How to get this substring on bash script? After downgrading, my Ruby 1.9+ versions went back in fine, but 1.8.7 won't install again. This is a regression that I introduced in the last release.

rvm reinstall 1.8.7 --with-gcc=/usr/local/bin/gcc-4.2 didn't work. I have tried multiple ways to supply the configure-options in various ways (set it as an env var, prepend like above, try to pass as command-arg) but it keeps failing with Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. That should get anyone from zero to ruby+gosu game development very quickly on Ubuntu 14.04, but if anything fails on x86, or elsewhere, please comment and let me know.Hope this helps

Browse other questions tagged make or ask your own question. now its coming up this [email protected]:~$ sudo apt-get install build-essential libsdl2-dev libsdl2-ttf-dev libpango1.0-dev libgl1-mesa-dev libfreeimage-dev libopenal-dev libsndfile-dev libiconv-hook-dev libxml2-dev freeglut3 freeglut3-dev ImageMagick libmagickwand-devReading package lists... Can anyone point me in the right direction? The mortgage company is trying to force us to make repairs after an insurance claim How to handle a senior developer diva who seems unaware that his skills are obsolete?

Terms Privacy Security Status Help You can't perform that action at this time. Installing Ruby from source to: /Users/databyte/.rvm/rubies/ruby-1.8.7-p370, this may take a while depending on your cpu(s)... Browse other questions tagged ruby xcode rvm osx-mountain-lion or ask your own question.